Message Body Box Issues

Questions, answers, suggestions and/or opinions about this web board or, the Isle Royale Info web site. If it's a Web Board or Web Site operational question, check here for an answer or, to ask a question.

Moderator: fonixmunkee

User avatar

Topic author
Rafiki
IR Expert
Posts: 502
Joined: Thu Apr 08, 2010 11:11 am
Isle Royale Visits: 4
Location: Chicago, IL

Message Body Box Issues

Post by Rafiki » Mon Mar 26, 2012 6:23 pm

Now before anyone gives me greif about typing too much, I warn you in advance :P So here is my problem and maybe its not a problem at all with the site, but I think it is because both my laptop and desktop have the same issue. When I write a message as I am doing right now in this message box, once I get down to the bottom of the message box, that is when the scroll tool becomes activated, my box forces me to view the top of the message box as I write below the begining of the scroll line. This prevents me from seeing what I am writing as I write it and it makes a constant jttering visual effect on my screen from shifting back at forth to where I am typing back to the top of the screen for each letter I push. Has anyone experienced this problem before? How can I stop this from happening or is this just something I will have to live with? Earlier today it was doing this and I just decided to write 4 seperate replys to the individuals that commented on a post I created rather that writing my reply all in one message. If this can be corrected or fixed, I would greatly appreciate it. Thanks.
4 Trips - 254 Miles Hiked: 2004 (3 Days), 2010 (11 Days), 2011 (13 Days), 2012 (8 Days)

User avatar

fonixmunkee
Forum Moderator
Posts: 797
Joined: Tue Sep 11, 2007 10:58 am
Isle Royale Visits: 12
Location: Soupe Towne, WI
Contact:

Re: Message Body Box Issues

Post by fonixmunkee » Tue Mar 27, 2012 7:10 am

Raifiki,

I just duplicated the issue on this post. It appears to do it for me when I get the scroll bar activated and I'm hitting the space key. Can you confirm that?

I'll start troubleshooting the problem a bit. I'm thinking it's probably the green theme on the forums. It's about two years old, and might need to be changed to something that has code built to be friendlier to newer browsers.
Sometimes you feel like a nut :: http://twitter.com/fonixmunkee

User avatar

Topic author
Rafiki
IR Expert
Posts: 502
Joined: Thu Apr 08, 2010 11:11 am
Isle Royale Visits: 4
Location: Chicago, IL

Re: Message Body Box Issues

Post by Rafiki » Tue Mar 27, 2012 5:00 pm

Ha Ha Ha now when I try to duplicate the problem the message body wants to play nice and not cause any problems. If I remember correctly, it was occuring whenever I clicked a letter or the space key and not just the space key alone. I will keep your question in mind next time the problem happens. Sorry I dont have specifics for you at the current moment.
4 Trips - 254 Miles Hiked: 2004 (3 Days), 2010 (11 Days), 2011 (13 Days), 2012 (8 Days)

User avatar

Topic author
Rafiki
IR Expert
Posts: 502
Joined: Thu Apr 08, 2010 11:11 am
Isle Royale Visits: 4
Location: Chicago, IL

Re: Message Body Box Issues

Post by Rafiki » Thu Mar 29, 2012 6:27 pm

Update. As I thought, the issue I am consistently experiencing happens both when pressing the space nar and any other key that causes something to be typed onto the screen. It makes writing messages distracting and causes me to take longer to write them :cry:
4 Trips - 254 Miles Hiked: 2004 (3 Days), 2010 (11 Days), 2011 (13 Days), 2012 (8 Days)


LeftOvers
Trailblazer
Posts: 152
Joined: Sun Mar 28, 2010 5:39 am
Isle Royale Visits: 15
Location: Wisconsin

Re: Message Body Box Issues

Post by LeftOvers » Fri Mar 30, 2012 4:58 am

I've never had those problems (and I tried just now), but sometimes my message seems to long and I can't type anymore. Is there a character limit to posts?

User avatar

fonixmunkee
Forum Moderator
Posts: 797
Joined: Tue Sep 11, 2007 10:58 am
Isle Royale Visits: 12
Location: Soupe Towne, WI
Contact:

Re: Message Body Box Issues

Post by fonixmunkee » Fri Mar 30, 2012 7:08 am

Leftovers, the limit on a reply is 60,000 characters. If you are hitting that, please make sure you aren't retyping the Encyclopedia Britannica into the message box :)

Still can't find any indication of an issue with the forum software (PHPBB 3.0), but I'm still exploring. Standby for more info.
Sometimes you feel like a nut :: http://twitter.com/fonixmunkee

User avatar

Topic author
Rafiki
IR Expert
Posts: 502
Joined: Thu Apr 08, 2010 11:11 am
Isle Royale Visits: 4
Location: Chicago, IL

Re: Message Body Box Issues

Post by Rafiki » Fri Mar 30, 2012 9:30 am

Thanks for continuing to stay on top of it munkee and trying to find a solution. I appreciate it.
4 Trips - 254 Miles Hiked: 2004 (3 Days), 2010 (11 Days), 2011 (13 Days), 2012 (8 Days)


LeftOvers
Trailblazer
Posts: 152
Joined: Sun Mar 28, 2010 5:39 am
Isle Royale Visits: 15
Location: Wisconsin

Re: Message Body Box Issues

Post by LeftOvers » Fri Mar 30, 2012 4:11 pm

fonixmunkee wrote:Leftovers, the limit on a reply is 60,000 characters. If you are hitting that, please make sure you aren't retyping the Encyclopedia Britannica into the message box :)
I wasn't close to typing an encyclopedia - I don't know enough words even if I repeat them a lot. :D Maybe the moon was full.
Only had the problem once, but I've been aiming for brevity ever since.

User avatar

fonixmunkee
Forum Moderator
Posts: 797
Joined: Tue Sep 11, 2007 10:58 am
Isle Royale Visits: 12
Location: Soupe Towne, WI
Contact:

Re: Message Body Box Issues

Post by fonixmunkee » Mon Apr 02, 2012 8:10 am

LeftOvers & Rafiki, et al.,

I believe I have the problem with the message box issue isolated down to a theme problem. To test this out, I've installed a new theme. Can you switch to the new theme and then try typing a long message and see if the message body still does the same thing? The theme is called "eTech Dark Green."

To switch to a new theme:

1. Go to your "User Control Panel"
2. Select "Board preferences" (or click here)
3. In the area titled "My board style:" change the theme to "eTech Dark Green"
4. Hit "Submit."

The theme should change after you click the "proceed" link that appears. You will notice if the new theme is in effect because the cool random IR image in the upper right-hand corner of the page will be gone, and there will be a generic "Our community" logo that appears in the middle-top.

As of right now, I'm typing this message and it's scrolling down the message box OK. That doesn't mean it's fixed for everyone with the new theme, so give it a shot and let me know if it works out.
Sometimes you feel like a nut :: http://twitter.com/fonixmunkee

User avatar

Topic author
Rafiki
IR Expert
Posts: 502
Joined: Thu Apr 08, 2010 11:11 am
Isle Royale Visits: 4
Location: Chicago, IL

Re: Message Body Box Issues

Post by Rafiki » Wed Apr 04, 2012 4:25 pm

Hey Fox. Thanks for continuing to put your efforts into solving this problem. I just changed the interface color, but cannot be certain if the problem is solved quite yet. The reason why I make this assertion is because the last time I checked to see if the problem was still occuring when you wanted me to determine if it happened only when I was pressing the space bar, the problem did not return. However, it did not return because I was copying and pasting a long message into the box and not actually typing it myself. It also did not occur when I typed something random like "dfklasdfjklh asdkjfhasd h fjksadfh sladhf sdlhkf sdkjf hasd" until the point where it took up the whole message box. So what I'll just have to do is wait around to see if it occurs when I type a long reply back to someone. Which is funny because this one is already getting long, and so with that said, the experiment begins lol I will have an answer shortly as I am one sentence away from going outside of the message box which will then initiate the scroll bar which will then either initate or not intiate the problem we have been speaking of. So far so good. I just got past the point of no return. Excellent I think we found a solution. Well lets just continue on to the other question I had for you in a new paragraph.

When I changed the color of the interface, which by the way I like a lot, I noticed these things called "Feeds" directly to the left of "Topics" and "Posts" on the list of board index items. I am betting they were there before, but I just now noticed them and must have thought them to be random icons that were placed there for no reason at all before I did the color change. In any regard, I clicked them and noticed that it was an area where side coversations occured on matters related to each item on the index. Can you elaborate a little more on what these "Feeds" are about. I am going to click around each of them and try to learn about them on my own, but if you could give me a brief understanding of what they are and why they are implemented I would greatly appreciate it.

So lovely news. I think the problem is offically solved. This is seriously the best day of my life, because I felt so limited to writing a short amount when sometimes I want to express myself thoroughly and give specific details on matters. Ok fine, so I like to ramble on a little too :roll: Thanks for the remedy Fox. I don't think I will be having this probelm again in the future, but if I do Ill let you know.
4 Trips - 254 Miles Hiked: 2004 (3 Days), 2010 (11 Days), 2011 (13 Days), 2012 (8 Days)

User avatar

Topic author
Rafiki
IR Expert
Posts: 502
Joined: Thu Apr 08, 2010 11:11 am
Isle Royale Visits: 4
Location: Chicago, IL

Re: Message Body Box Issues

Post by Rafiki » Wed Apr 04, 2012 4:51 pm

Hmmmm, so correct me if I am wrong, but it appears as though the "Feeds" are just a standard log and list of everything written on the particular index in a plain text format without any fonts, colors, or backgrounds? Almost like the skeleton of all that is written without the flesh and muscles to make it look pretty? Right? Sorry, best analogy I could come up with, I'm about to go do a workout out at the gym and it was the first thing that came to mind :lol:
4 Trips - 254 Miles Hiked: 2004 (3 Days), 2010 (11 Days), 2011 (13 Days), 2012 (8 Days)


LeftOvers
Trailblazer
Posts: 152
Joined: Sun Mar 28, 2010 5:39 am
Isle Royale Visits: 15
Location: Wisconsin

Re: Message Body Box Issues

Post by LeftOvers » Fri Apr 06, 2012 5:58 am

fonixmunkee, my issue was different from Rafiki's. Yesterday, I was able to recreate it, but didn't have time to respond here. It's not a problem, just an unexpected change in the way the message entry box works.

When I quoted someone, then entered my comments and reached the bottom of the message window, my carriage return had no effect, I didn't get a new line. I assumed I had reached a limit of some sort.

That didn't happen if I didn't quote someone. Get to the bottom, enter a carriage return, window scrolls and I get a new line. Fine.

When including a quote, if I had kept typing at the bottom of the window, the window would have scrolled. Enter a carriage return - it only looks like a new space (" ") at the end of the line and no scrolling. But type another letter after that carriage return and everything goes to a new line - no problem. Strange, though.

Thanks for looking into this.

User avatar

fonixmunkee
Forum Moderator
Posts: 797
Joined: Tue Sep 11, 2007 10:58 am
Isle Royale Visits: 12
Location: Soupe Towne, WI
Contact:

Re: Message Body Box Issues

Post by fonixmunkee » Fri Apr 06, 2012 7:23 am

LeftOvers wrote:fonixmunkee, my issue was different from Rafiki's.
Just out of curiosity, did you switch to the new theme?

If you did, this might be a problem with your browser, and we can try to resolve this fairly easy.
Sometimes you feel like a nut :: http://twitter.com/fonixmunkee

User avatar

Topic author
Rafiki
IR Expert
Posts: 502
Joined: Thu Apr 08, 2010 11:11 am
Isle Royale Visits: 4
Location: Chicago, IL

Re: Message Body Box Issues

Post by Rafiki » Wed Apr 11, 2012 9:19 pm

It's been a week since switching to the new interface color and I have not had anymore problems with the issue I discussed at the begining of this thread. Having said this, I hope that all newly registered users will automatically have this interface color set as their default. If not, at least they will have this thread as a reference should they experience the same problem I did.
4 Trips - 254 Miles Hiked: 2004 (3 Days), 2010 (11 Days), 2011 (13 Days), 2012 (8 Days)

User avatar

fonixmunkee
Forum Moderator
Posts: 797
Joined: Tue Sep 11, 2007 10:58 am
Isle Royale Visits: 12
Location: Soupe Towne, WI
Contact:

Re: Message Body Box Issues

Post by fonixmunkee » Thu Apr 12, 2012 8:32 am

Rafiki wrote:I hope that all newly registered users will automatically have this interface color set as their default.
After I incorporate the custom code into this theme, I'll be switching all forum users over to it.
Sometimes you feel like a nut :: http://twitter.com/fonixmunkee

Post Reply